Test SMTP Email Settings

Hi, I have a Synology NAS, running VaultWarden as a docker container.

I went to the Admin portal, SMTP Eamil Settings section, I filled out:

  • Enabled: true
  • Host: smtp.gmail.com
  • Enable Secure SMTP: true
  • Force TLS: false
  • Port: 587
  • From Address: [my gmail email address]
  • From Name: my made up name
  • Username: [my gmail email address]
  • Password: a specific app password made just for this
  • SMTP Auth mechanism: [blank]

I saved it and when I test it, it says: Error sending SMTP test email, undefined.

I flipped over to the “Log” tab in the docker window, nothing shows there.

Thoughts/suggestions are greatly appreciated!

Try the setting I use for gmail

(When tested secure SMTP works both enabled and disabled) Enable Secure SMTP: false
Force TLS: True
Port: 465

Edit: corrected SMTP port

sorry, port 455 is not a standard port for SMTP delivery, I am sure the network admin won’t open it…

Anyway, I tried another account and it works now…

Thanks…

My apologies, I mistyped port 455 which should have been port 465, please see Send email from a printer, scanner, or app - Google Workspace Admin Help

I believe you can get it working with port 587 as well but may need both
Enable Secure SMTP: true
Force TLS: true

Try it, save the config, and test email outbound.

Also, wanted to check you have the proper firewall rule to allow outbound traffic on whatever outbound SMTP port you use. Either UPNP mostly in home use or the proper firewall rule to pass outbound traffic on the SMTP port to the internet, or Google’s SMTP servers.