Synology/SMTP Unable to send email

Hello everybody,

I’m really new to Vautwarden, and I’m trying to setup my SMTP settings (admin panel and environment variables).

For now I’ve tried a lot of setups, but I’m always getting a SMTP timeout error (504).

For some context, I’m running Vaultwarden on my Synology NAS. I already tried to setup with my personal domain, a Outlook account and a Gmail account, always with the same result 504.

My own domain (the default setup, from the container env var.):
personal setup

Do you see anything wrong with this settings? Maybe I’m missing something?

Thanks in advance for all the help,

Best regards,

Hello to all,

I’m doing some other tests (this time with Gmail), I have some news but still unable to make it work. Here are my settings:

  • host:
  • secure SMTP: checked
  • force TLS: unchecked
  • port: 587
  • from address: my gmail address
  • from name: Vaultwarden
  • Username: my gmail address
  • password: my gmail APP password
  • SMTP Auth mechanism: empty
  • SMTP connection timeout: 30 (or 60)

When doing this setting, I’m getting 2 kinds of errors:

  • if SMTP connection timeout = 60 => Undefined
  • if SMTP connection timeout = 30 => SMTP Connection error: Cannot assign requested address (os error 99)

Thanks again for the help,

Best regards,

I’m not using Gmail but all the settings you have match mine except I have “plain” as the SMTP auth mechanism, including the quotes. I also have Accept Invalid Certs ticked. I set these up in the admin webpage.

Can the Nas send its own emails ok?

Hello daveymg,

Thanks for the reply. Since yesterday I’ve tried a lot of possible combinations, (plain, login, both, …, invalid certs checked and unchecked), but I’m always getting the same error 99 (timeout = 30).

What do you mean by “The NAS can end its own emails”?

On my Synology (DS218+) I have the Mail Plus server/ client installed, and I use it mainly as a pop client fr my personal domain account, where I can send mails using it’s SMTP setup.

I didn’t managed to make it work, so I decided to also try Gmail…

EDIT : I did retry my personal domain email, but there I’m getting error 400 Bad Request. I submit a help ticket with them, I’ll keep you posted

Ok, I found.
It was actually related to the fact that Vaultwarden use a bridge network on Synology. I had to add a firewall rule on the NAS to allow the bridge IPs (