[SOLVED] Android client can't sync vault

Hi there!

I have a working BitRS server (can use my desktop, firefox and chrome apps) but something it wrong with Android.

I can log in to my vault using Android Bitwarden client, but it fails to sync any data. I can see the request on my proxy
"GET /api/sync HTTP/1.1" 200 1116956 "-" "Bitwarden_Mobile/2.5.0 (Android 8.0.0; SDK 26;

and same on my BitRS server
bitwarden_rs[14007]: [2020-07-16 04:56:11][request][INFO] GET /api/sync
bitwarden_rs[0]: [2020-07-16 04:56:11][request][INFO] GET /api/sync
bitwarden_rs[14007]: [2020-07-16 04:56:11][response][INFO] GET /api/sync?<data..> (sync) => 200 OK
bitwarden_rs[0]: [2020-07-16 04:56:11][response][INFO] GET /api/sync?<data..> (sync) => 200 OK
bitwarden_rs[14007]: [2020-07-16 04:56:12][request][INFO] GET /api/sync
bbitwarden_rs[0]: [2020-07-16 04:56:12][request][INFO] GET /api/sync
bbitwarden_rs[14007]: [2020-07-16 04:56:12][response][INFO] GET /api/sync?<data..> (sync) => 200 OK
bitwarden_rs[0]: [2020-07-16 04:56:12][response][INFO] GET /api/sync?<data..> (sync) => 200 OK

But Android client is reporting “Can’t sync” error…

Please advice where to look at.

I have my nginx on a proxy as follows:
location / {
proxy_headers_hash_max_size 512;
proxy_headers_hash_bucket_size 64;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

	`add_header Front-End-Https on;`
`location /notifications/hub {`
	`proxy_set_header Upgrade $http_upgrade;`
	`proxy_set_header Connection "upgrade";`


`location /notifications/hub/negotiate {`
	` proxy_pass;`

What version of bitwarden_rs are you running? You should be on 1.15.0 or later at this point.

Version 1.15.1-1e950c7d

Web Vault is 1.15.2

Client is
2.5.0 (3039)

Same error with 2.3.1 (2257)

Ok, I think we can close the issue… But I do not have any explanation for it.

I downloaded APK from Bitwarden Git repo (both an f-droid and normal versions).
So I removed the GooglePlay version and installed one from Git (non f-droid => com.x8bit.bitwarden.apk) and restarted my BitRS service…

And magic happened - it now syncs with no issue!

P.S. It may help others I think =)