SMTP Unable to Send Email

I am unable to send any email via SMTP. I have a working instance other than that, it seems that way so far anyway. I get this error from the admin panel and from the send validation email when you log into the vault. I have tried Google, M$ and my own SMTP information, which I have confirmed all working.

[2020-06-11 19:23:04][bitwarden_rs::api::identity][ERROR] Error sending new device email: SmtpError.
Os {
code: 11,
kind: WouldBlock,
message: “Resource temporarily unavailable”,

I have no other warnings or errors in the logs. Any ideas or need any additional info from me?

docker-compose info:

container_name: bitwarden
image: bitwardenrs/server:latest
restart: always
- no-new-privileges:true
- $USERDIR/docker/bitwarden:/data
- /var/log/docker:/var/log/docker
- /etc/timezone:/etc/timezone:ro
- /etc/localtime:/etc/localtime:ro
- SIGNUPS_ALLOWED=true # Change to false after first login
- INVITATIONS_ALLOWED=true # Send invitation using admin page
- LOG_FILE=/var/log/docker/bitwarden.log
- SMTP_SSL=true
#- DISABLE_ADMIN_TOKEN=true ### USE WITH CAUTION!! Access admin page at bw.$DOMAINNAME/admin to send invitations - anyone can access, add authorization!!!
- “traefik.enable=true”
## HTTP Routers
- “traefik.http.routers.bitwarden-rtr.entrypoints=https”
- “traefik.http.routers.bitwarden-rtr.rule=Host(bw.$DOMAINNAME)”
- “traefik.http.routers.bitwarden-rtr.priority=10”
- “traefik.http.routers.bitwarden-rtr.tls=true”
## Middlewares
- “traefik.http.routers.bitwarden-rtr.middlewares=chain-oauth@file” # Google OAuth 2.0
## HTTP Services
- “traefik.http.routers.bitwarden-rtr.service=bitwarden-svc”
- “”
## Bitwarden WebSocket
- “traefik.http.routers.bitwardenHub-rtr.entrypoints=https”
- “traefik.http.routers.bitwardenHub-rtr.rule=(Host(bw.$DOMAINNAME) && Path(/notifications/hub))”
- “traefik.http.routers.bitwardenHub-rtr.priority=20”
- “traefik.http.routers.bitwardenHub-rtr.tls=true”
- “traefik.http.routers.bitwardenHub-rtr.service=bitwardenHub-svc”
- “”

[edit 2]
My BW domain is different than my SMTP domain. I can’t see why this would bother anything…

It looks like the smtp server is not reachable with the parameters given.
Please check if the host and port are correct.

Thanks for the reply.

No matter what I place in the admin settings this is the error:

[2020-06-16 15:01:57][error][ERROR] SmtpError.,
[CAUSE] Io(,
Os {,
code: 11,
kind: WouldBlock,
message: “Resource temporarily unavailable”,
[2020-06-16 15:01:57][response][INFO] POST /admin/test/smtp (test_smtp) => 400 Bad Request,

I have many other apps working from the same server, all using the same SMTP credentials. Any advice?

Is DNS working?
You could check the diagnostics page in the /admin interface.

Also, try to increase the smtp_timeout from the default 15 to 30 or 60 even and see what happens then.

Please see screenies below. Still failed at 60. I assume diag page is OK.

Just to be sure, you did do a save of the settings when you changed the timeout to 60 before you tried the test again right?

If so, was the error message still the same?

:laughing: Upon your first reply, when I tested again this morning, I thought I was forgetting to click save each time, turns out I was indeed clicking save this time and the prior times.

Anyway, yes, the same error. It doesn’t seem to matter what I put in there, just the same error over and over with working / non-working SMTP credentials.

All I know for sure is, it is specific to this container. I was hoping there would be lots of other info on the forums/github but alas, it seems to be me. I just wish there was a better error message to go off of.

Follow Up Here:

Outlook SMTP working
GMAIL SMTP working
Personal SMTP not working - I have no idea why not. It works on all my other apps.

Anyway, I’m just happy one of them is working. Maybe it was an update, maybe I am fried. WHO knows!

Have you checked if “Less secure Apps” is authorized in your Gmail / Google account ?
Google Account / Security
Less secure App -> Autorize.

To be more secure:
Activate 2FA autentication ingoogle account
Then Create an App-specific Password.

I used the less secure option for gmail. I wont be using their service but thanks for following up!