Problems with Apps on Mac and iOS

Hello Vaultwarden Community,

I’ve recently Setup my private Vaultwarden instance on my RaspberryPi 4B

It’s deployed via the docker image on an extra Portainer stack (docket compose)

The Ports are forwarded via Nginx Proxy Manager on a custom Docker Network.
(Bridge Network)
Websocket support is enabled.

The Instance itself is working perfectly in net and Windows Clients.

My Problem is that it’s not working on Mac neither IOS apps. The IOS is giving me an SSL Error and MacOS just Load Error or Failed to Fetch.

Using Bitwarden Apps available in AppStore

I hope you can help me. I can also provide my Configuration if required.

Are you using a valid SSL cert?
Otherwise you will probably need to install your certificate chain to your device’s root store for iPhone and Mac.

I have an automatically assigned Cert by Let’s Encrypt

Is this issue resolved? If resolved how did you resolved it? I am also facing the same kind of a problem

my issue is below

I recently installed vaultwarden on Synology docker and was able to access the web over desktop and iphone. However iOS app fails to connect with this error "We were unable to process your request. Please try again or contact us”. When I check the logs on the docker there is absolutely no hit happening.

Also, I noticed one important thing on my desktop. I tried logging into bitwarden chrome extension and it always failed. It succeeded only after logging on the chrome browser web interface.


I don’t think https is an issue as I access my web, google chrome extension using There is absolutely no hit happening to vaultserver as I had enabled debug in the logs and no request is hitting the server when I try to login using iOS App.

Okay my error is resolved.

I’m not sure what the Problems have been it just worked. Maybe an SSL Cert that had to be synced trough dns servers.
It wouldn’t really make sense cause I was waiting far more that 72 Hours.

Have you activated Websockets on you reverse Proxy and docker Container?
Env Var:

Thank you so much websocket_enabled = true made the issue resolved and I am able to login without any hurdle. Thanks much for the help.

1 Like

Just to get rid of a misconception here.

web-sockets have nothing to do with the login process!
Also, web-sockets do not even work on mobile clients, since the mobile clients do not have web-socket support built-in at all.

It more looks like the whole container needed to be restarted, or re-created for the certs to be fully working, since they are only read during startup, and not on-the-fly when changed.

So, enabling web-sockets would not have fixed your mobile client login issue, but probably the restart/re-creation of the container did.

Just saw your post. I had a similar headache recently.
For the SSL error on iOS, it might be an issue with the certificate not being fully trusted. Check if your SSL certificate is correctly installed. iOS can be picky about these things, especially with self-signed certs.
On your Mac, the “Failed to Fetch” error could be a network problem. Double-check those network settings and port configurations in your Nginx Proxy Manager to ensure everything’s lined up right.
Also, a quick tip: keeping your Mac in tip-top shape can sometimes solve weird issues. You can find more details on managing memory space on your Mac here: