[DSM7][DOCKER][1.2.2] - Can't confirm user


i have install vaultwarden in docker version on my synology :


Server Installed Ok


Server Latest


Web Installed



SQLite: 3.35.4


Running within Docker


Environment settings overridden


Uses a reverse proxy


IP header Match

Config/Server: X-Real-IP

Internet access Ok


Internet access via a proxy


i can create organization and user.
my user received confirmation mail, accept it, create his account and verify mail.
all is good after this, i see him in the organization manage tab.

but i can’t confirm user, the popup appear but is empty, like this :

in the log file i see this :
[2021-08-26 05:26:33.209][response][INFO] GET /api/organizations/<org_id>/users (get_org_users) => 200 OK
[2021-08-26 05:38:42.557][request][INFO] POST /api/organizations/19e5bd76-b310-41c7-8aca-7b56e5ee7d72/users/public-keys
[2021-08-26 05:38:42.558][response][INFO] POST /api/organizations/<org_id>/users/<org_user_id> (edit_user) => 422 Unprocessable Entity

i tried to delete all user and organization and retry again but i’ve got the same error.
i tried with two user and it’s the same thing.

could you help me please ?

thank you :slight_smile:

Being that docker containers are ephemeral, you may try to delete the Vaultwarden docker (make sure you have a volume where all your data lives) then pull down the latest docker image again and attach the previous volume mount to the new docker container.
Hopefully it could be just an issue with the container.

Past that, you mentioned the issue happened with new users and a new organization as well as two separate users. Are there any other commonalities? Trying different web browsers, possibly clearing browser cache, or using separate computers for each user?

I use a persistent volume for the container.

Finally, it works but only if i use the option button in front of user mail, i mean :
if i use this :

i’ve got the empty popup.

but if i use this button for ask to confirm :

Confirmation is ok.
I test it after deleting my container and creating a new one and in different browser (safari + brave)

It’s look like it’s a web interface bug but not back office .