Cannot invite/re-invite users to organization

Hi all,

Today, I tried to invite a new user to my organization using their gmail email address and I got an error. I then tried to invite another user that uses the same domain as mine, and it failed with same error. I am on the latest version of the Vaultwarden docker image.

This is what I see in the container logs:

Matched: POST /api/organizations/<org_id>/users/<user_org>/reinvite (reinvite_user)
Error: Address.
[CAUSE] InvalidDomain
    => Outcome: Success
POST /api/organizations/<org_id>/users/<user_org>/reinvite (reinvite_user) => 400 Bad Request
    => Response succeeded.
GET /:
    => Matched: GET / (web_index)
    => Outcome: Success
    => Response succeeded.

Says Error: Address, but not sure what that means as the email I type is valid: or user@domain.tld.

This is what I see when I am logged into the web gui:
Screen Shot 2021-11-09 at 4.55.09 PM

Any thoughts or ideas?


Could you post the support string which you can generate via the /admin/diagnostics page?

When I go to domain.tld/admin, I get the message below:

The admin panel is disabled, please configure the 'ADMIN_TOKEN' variable to enable it

But I have the ADMIN_TOKEN=random already setup in my docker-compose file.