Bitwarden/Vaultwarden can’t connect on Windows via Browser-plugin

i need help with my selfhosted Vaultwarden on Synology NAS. I’ll set everything up on the NAS/reverse proxy etc., it works on NAS, on all android devices but not on windows Browsers such as Chrome, FF, Opera on their plugin Bitwarden.

When i setup Bitwarden connection to my NAS i still get Error mesage: failed to fetch.

any idea why it doesn’t want to work?

Thanks for help.

Perhaps more detail would be of assistance to diagnose the issue here.
I presume as you’ve said you successfully got the android applications to work you are familiar with setting the URL for your self-hosted instance.

Can you confirm you’ve done this for the browser extensions? Is your Vaultwarden publicly accessible or is it only a private instance?
How are you trying to connect, with IP or hostname? And do you have a valid certificate installed?

1 Like


Yes the selfhosted vaultwarden is publicly accessible with valid certificate. I connect via ddns hostname - it works via web and android app, but on windows via Browsers plugin dont.

Sorry for the screenshot it is in slovak language.
I dont understand it works publicly via web, on android Phone/ Tablet but on any windows Browser: Chrome/Opera/FF dont.

I try connect via external IP and i get the error 404 not found nginx

You have not answered if you have connected the extension to your server?
I.d. if you have filled out this field:
Setting the Server URL

Yes i have connected the extensions in bitwarden plugin for webBrowsers same as in the android app.

The Point is selfhosted Vaultwarden works well but only on android app Bitwarden with all the necessary settings, not on windows webBrowser Chrome etc… Bitwarden plugin! and i do not know why?
i get the Error failed to fetch.

I am assuming with using a duckdns subdomain, is this duckdns subdomain only used for the Vaultwarden service?
Or do you know if this was bound to a specific port or subdir/sub-path?

Its only for the Vaultwarden.

Put the Bitwarden browser extension into developer mode (Frequently asked questions - Chrome Developers). A new Inspect views section should appear, with a clickable “background.html” link that opens up a DevTools view that shows the network log. Attempting to log in should now show what failed to fetch.

Hi, i found this see below, and I didn’t know much about that :confused:

You should look at the Network tab. Your prelogin call failed, but you didn’t show the full path.

You can also look at your Vaultwarden log for failed prelogin requests. You might be encountering

though I don’t think that has been seen with the browser extension before.

you mean this

i am not very familiar with this, and docker and all this stuff are all new for me :frowning:
I probably have a long way to go … if I don’t give up
I thought it would be quite simple as in the tutorials, but nothing can be easy for me :neutral_face:

The link you provided is a DuckDNS link but with an optional non standard port 2243, are you making sure you are entering the port in as well when you are putting in the entire DuckDNS URL.

Typically web services are bound to either port 80 http or 443 https and this is what is expected by most browsers and programs when going to some site.
Other programs, i.e SSH port 22 will have different default standard ports.
Ports can be changed but the program will have no way of knowing you have changed your port to something different than the default it is expecting unless you specify the correct port.

i add the port to in the url, as by the android app where it works.

Hi :slight_smile: so i have a solution for this issue i do not why but the Browser plugin of Bitwarden in windows doesnt like other ports as 443 (android app it doesn’t matter), even when the exact port on the server is set! soooo Port 443 is a must! :slight_smile:

Problem solved. :slight_smile: