Android won't sync when not on home network

I am new to the group so I apologize in advance if I am posting incorrectly. Please steer me in the correct direction and I will definitely listen.

I am new to the self-hosting of Vaultwarden. Previously I was using Keepass and just syncing my Android with my NAS.

The issue I am having is that I cannot create any new logins nor sync when I am not directly connected to my home network.
I just know there is something I am missing or may have mis-configured, but after hours of searching, darned if I can find it.
If someone could please push me in the right direction, I would really appreciate it.
Other than that small little issue, I am LOVING my self-hosted docker of Vaultwarden.

Thanks so much!

If you are unable to sync when off of your home network then it sounds like you have no access from the greater internet and only on LAN.

This could either be due to something simple like a firewall rule, or port forward issue.
Could possibly be a DNS issue if you do not have the proper records on your external DNS.

Possibly internal only access is preferred without opening your network to the greater world wide web, in this case you would need a home VPN connection back to your internal LAN, this would allow you to keep your Vaultwarden instance closed off from the rest of the world but still allow you to access it securely over VPN in a manner similar to being on your home network.

Thanks for the quick feedback!

I had followed a tutorial on how to setup reverseproxy on Synology and YES(you are correct). I had used recommended ports (5554 for external). I figured it out this AM. I removed all of that and went with the setup of sticking with 443 but using “wildcard certificates” instead.
Bingo! It works. Weird thing is, it WAS working the original way for several hours.
But… I’m not going to try and chase down why it stopped. This works and that’s good enough for me.

Thanks again for providing such quick and friendly feedback!

I’d like to mark this as solved but I don’t really know how. Like I said, I’m very new to forum posting.

I’m having the same issue. Vaultwarden hosted via Docker on Synology, reverse proxy and Using OpenVPN. While off network I can connect to VW but edits, syncs will not complete. How did you solve the issue? Warning, this is all new territory for me and the simplest, most detailed explanation would be most appreciated! Any help will be appreciated…

These are the main two sites I used to get mine working. These guys seem to really know their stuff and their web sites are very informative and easy to follow.
Setup Bit(Vault)warden on Synology:

Then the issue I was having with accessing when NOT on my home network I solved following this: