When logging in it take around 30 seconds to load the vault

I’m sure I will need to provide more information but I run vaultwarden in docker behind traefik. I don’t think there is a problem with my setup as I run a number of services behind the reverse proxy with the same configuration and no issues.
When logging in, the interface comes up very quickly but the in the My Vault and Organisations sections there is just a swirling circle for 20-30 seconds.
I have only a few hundred passwords and 7 organisations.

The relevant gap in the logs is shown by the following two entries

vaultwarden | [2021-12-07 12:17:13.680][request][INFO] GET /api/sync?excludeDomains=true
vaultwarden | [2021-12-07 12:17:33.794][response][INFO] GET /api/sync?<data…> (sync) => 200 OK

Any clues or solutions as to how to prevent this delay?

That could happen if your storage or database isn’t very nearby. See

The symptoms certainly seem similar. I’m in docker and don’t specify a database. It looks to be using sqlite. The db files are accessed via NFS over a 2.5Gb link, could this be the bottleneck?

If this is the issue then I can see two options. Firstly move the container data directory locally so that there is no NFS access. Or switch to a proper DB like mariadb. The first is fairly easy to accomplish, the latter I’ll need to work out how to perform that migration.

This performance issue is more related to latency than bandwidth, so it depends on how far away your NFS server is. Similarly, if your MySQL/PostgreSQL server is not very nearby, you will probably have similar issues.

IMO, most users would be best served running with SQLite on local storage and creating backups regularly.

NFS is less than a metre away and only 1 2.5Gb switch between them. About as low latency as its likely to get. I’m using sqlite so my plan is to bring it local and see how that affects things.

Longer term I’ll migrate to Maria dB and compare performance but will need to look up docs to find out how to migrate


I’ve moved the docker mount containing the sqlite database file onto the local machine and this has eliminated the delay and is now less than 1s to load everything.