Vaultwarden on Synology not working after upgrade

I’ve used the Container Manager to upgrade my vaultwarden installation. After the upgrade process was completed, it did not start and this is the error message:

Start container vaultwarden-server1 failed: {"message":"failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: \"/usr/bin/dumb-init\": stat /usr/bin/dumb-init: no such file or directory: unknown"}.

I’ve noticed that there is no project anymore in the Container Manager - I’ve never paid attention to this, but I guess this is what’s gone missing.
I’ve tried to set it up anew (create), but it’s failing when I complete the wizard with this error:

Local port 5151 conflicts with other ports used by other services.

I went into the CLI of my NAS and with netstat I searched for any service listening on port 5151 - nothing found.
This is how it looks like:

And this is the reverse proxy config:

Where am I doing wrong?
Thanks in advance for your help!

If you still have dumb-init in there you were using a very old version.

But basically your problem is the same as described here

I don’t know which version I was running, but it was for sure at least 1.5 years old.
As I’m very noob in all this: what (and how) should I now do, to correct the issue?
I’m not using Portainer.
I somehow understand that I need to remove something from the configuration - but I don’t know where/what.
Thanks for your help!

Please read or find the documentation of the tool you are using. Most of us won’t be familiar with it either…

And if you can’t figure it out: maybe you can recreate the setup from scratch with the same /data folder?

mmmhhh… the “tool” is actually the Container Manager from Synology…
Anyway: recreating the setup sounds good.
As long as I don’t remove or do anything with the /data folder, I’m safe not losing anything - correct?

Should I also first export everything from one of my Bitwarden clients - just to be “double-safe”?

OK - I somehow solved it.
I’ve deleted the old container and installed vaultwarden/server-latest again from scratch.
Now it works.
I was starting to follow instructions found here: Synology: Install Vaultwarden With Portainer – Marius Hosting
Do you suggest to use Portainer, or can I just remove it and continue using Synology’s Container Manager?

I am using the default Synology Container Manager, and no problems.

This is the setup I have for the Container Manager > Container:

   "CapAdd" : null,
   "CapDrop" : null,
   "cmd" : "/",
   "cpu_priority" : 50,
   "enable_publish_all_ports" : false,
   "enable_restart_policy" : true,
   "enabled" : true,
   "env_variables" : [
         "key" : "PATH",
         "value" : "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
         "key" : "ROCKET_PROFILE",
         "value" : "release"
         "key" : "ROCKET_ADDRESS",
         "value" : ""
         "key" : "ROCKET_PORT",
         "value" : "80"
         "key" : "DEBIAN_FRONTEND",
         "value" : "noninteractive"
         "key" : "SEND_PURGE_SCHEDULE",
         "value" : "0 0 5 31 2 ?"
         "key" : "TRASH_PURGE_SCHEDULE",
         "value" : "0 0 5 31 2 ?"
         "key" : "SMTP_PASSWORD",
         "value" : "EDIT_HERE_your_smtp_password"
   "exporting" : false,
   "id" : "EDIT_HERE__docker_id_some_hash_",
   "image" : "vaultwarden/server:latest",
   "is_ddsm" : false,
   "is_package" : false,
   "labels" : {
      "org.opencontainers.image.created" : "2023-11-05T23:08:37+00:00",
      "org.opencontainers.image.description" : "Unofficial Bitwarden compatible server written in Rust - 1.30.0",
      "org.opencontainers.image.documentation" : "",
      "org.opencontainers.image.licenses" : "AGPL-3.0-only",
      "org.opencontainers.image.revision" : "EDIT_HERE_some_hash_super_long",
      "org.opencontainers.image.source" : "",
      "org.opencontainers.image.url" : "",
      "org.opencontainers.image.version" : "1.30.0"
   "links" : [],
   "memory_limit" : 0,
   "name" : "vaultwarden",
   "network" : [
         "driver" : "bridge",
         "name" : "bridge"
   "network_mode" : "bridge",
   "port_bindings" : [
         "container_port" : 80,
         "host_port" : 8083,
         "type" : "tcp"
   "privileged" : false,
   "shortcut" : {
      "enable_shortcut" : false,
      "enable_status_page" : false,
      "enable_web_page" : false,
      "web_page_url" : ""
   "use_host_network" : false,
   "version" : 2,
   "volume_bindings" : [
         "host_volume_file" : "EDIT_HERE_/where_are_you_storing_the_files_and_data_base_at_your_nas/vaultwarden",
         "is_directory" : true,
         "mount_point" : "/data",
         "type" : "rw"

Notice the EDIT_HERE_ for adding your personal information.

Here is my setup at Control Panel > Login Portal > Advanced > Reverse Proxy:

Nothing set on Web Station.

And check your firewall, at Control Panel > Security > Firewall > Edit Rules.
Check if the ports of Vaultwarden network are open.

Check which ports are being used from: