Vaultwarden keeps loading

Hello,

I am self hosting a Vaultwarden instance. I am running it as follows:

docker run -d --name vaultwarden -v /vw-data/:/data/ -e ROCKET_PORT=8088 -e DOMAIN=https://<MY DOMAIN> -e WEBSOCKET_ENABLED=true -p 8088:8088 -e WEBSOCKET_ADDRESS=127.0.0.1 -e DOMAIN_ORIGIN=https://<MY_DOMAIN> vaultwarden/server:latest

When I try accessing it through a Web browser, I get a loading page that never ends. Or a blank page with only “Bitwarden” written.
I checked the docker logs and I get this:

/--------------------------------------------------------------------\
|                        Starting Vaultwarden                        |
|                           Version 1.27.0                           |
|--------------------------------------------------------------------|
| This is an *unofficial* Bitwarden implementation, DO NOT use the   |
| official channels to report bugs/features, regardless of client.   |
| Send usage/configuration questions or feature requests to:         |
|   https://vaultwarden.discourse.group/                             |
| Report suspected bugs/issues in the software itself at:            |
|   https://github.com/dani-garcia/vaultwarden/issues/new            |
\--------------------------------------------------------------------/

[INFO] No .env file found.

[WARNING] The following environment variables are being overriden by the config file,
[WARNING] please use the admin panel to make changes to them:
[WARNING] DOMAIN

[2023-01-09 13:51:56.557][vaultwarden::api::notifications][INFO] Starting WebSockets server on 127.0.0.1:3012
[2023-01-09 13:51:56.559][start][INFO] Rocket has launched from http://0.0.0.0:8088

Everything is green in the diagnostic page. The instance worked just fine until yesterday and I didn’t change anything in particular.
Does anybody know what the problem may come from?

Thanks!

There isn’t anything useful in the data you posted.
Is it still not running right now? Is it still going down?

What do the logs say from Vaultwarden, Docker and your Host.
There must be something there.

The logs from Docker give me this when I try accessing my instance from a web browser:

[2023-01-09 14:49:24.053][_][WARN] Remote left: channel closed.
[2023-01-09 14:49:24.054][_][WARN] Remote left: channel closed.
[2023-01-09 14:49:24.054][_][WARN] Remote left: channel closed.

When I try to access my vault from the Bitwarden Android app, it opens but it appears empty (although I can see it is not from the admin panel) and I get this log from Docker:

[2023-01-09 14:46:59.188][request][INFO] GET /api/sync
[2023-01-09 14:46:59.193][response][INFO] (sync) GET /api/sync?<data..> => 200 OK

Problem solved. It actually had nothing to do with Vaultwarden, my server ran out of disk space.
Sorry for the useless post!

1 Like

I don’t think it’s useless. It may help us diagnose the problem when others have the same issue. :+1:

1 Like