Fresh install web interface timeout

I can’t seem to install Vaultwarden correctly it times out is unresponsive.

I was Trying to switch from bitwarden because I’m in some glitch that it will not update.

I installed fresh Ubuntu 22.4 and fresh Vaultwarden but I can’t get to the web interface even with disbaleing ufw or enableing it and allowing ports 80 an 443 .

Please provide more information about what you tried and what did not work.

I followed the directions on your site. I Get Telnet to localhost on port 80 I even get telnet 80 to work from same ssh session but when I go to load it in the browser I get either un responsive or timeouts messages … it’s been over a week. and I tore The VM down. I’ll build another one. when I get a moment and try it again. but in regards to what I tried I put all that into the original post I don’t know what else to try.

I’m having the same issue. Here’s my docker-compose.yml file:

    pod: "bitwarden"
    image: vaultwarden/server:latest
    container_name: vaultwarden
    restart: always
      WEBSOCKET_ENABLED: "true"  # Enable WebSocket notifications.
      - ./vw-data:/data:Z
      - 80:80/tcp

Here’s what the console says:

|                        Starting Vaultwarden                        |

|                           Version 1.28.1                           |


| This is an *unofficial* Bitwarden implementation, DO NOT use the   |

| official channels to report bugs/features, regardless of client.   |

| Send usage/configuration questions or feature requests to:         |

| or        |

|                             |

| Report suspected bugs/issues in the software itself at:            |

|            |


[2023-04-10 04:10:03.167][vaultwarden::api::notifications][INFO] Starting WebSockets server on

[2023-04-10 04:10:03.169][start][INFO] Rocket has launched from

I already checked the server’s firewall, and port 80 is open. when I try to go to http://(LAN IP of server), the connection times out.

I am using AlmaLinux 8 for the OS.


I got the container to work using this command:
docker run -d --name vaultwarden -v ./vw-data/:/data/:Z -p 80:80 vaultwarden/server:latest
NOTE: the :Z is for SELinux. remove it if your linux distribution doesn’t use it.

AFAIK there’s some sort of issue with port-forwarding when using docker-compose. I am not sure what it is, but it’s not working with docker-compose.
2nd NOTE: RHEL-based systems use Podman. Although I see @blindrain having issues with Ubuntu, so it’s that Podman isn’t causing any issues.

@blindrain you might want to try runing the command above (remove the :Z before you do).

Lastly, if you do get this to work, you may have need to enable the admin page.