Update 1.29.1 -> Latest (1.30.0)

Hi @all,
i tried to update vom 1.29.1 to 1.30.0 but it doesn"t work.
Portainer shows that the new version is running but it doesn’t work.
The first thing I noticed is that the container is no longer assigned a port. This means that it can of course no longer be reached. Are there logs somewhere where you can perhaps get a hint?
I used the following procedure:

docker pull vaultwarden/server:latest
docker stop vaultwarden
docker rm vaultwarden
docker run -d \
--restart always \
--name vaultwarden \
-e ADMIN_TOKEN=**** \
-v /bw-data/:/data/ \
-p 8080:80 vaultwarden/server:latest

I have no idea where to start to solve this issue.
Someone who can help me?

Thank you

I did the upgrade (two instances of vaultwaren) a few minutes after the release of 1.30, and both went just fine.

I use docker (not portainer), but otherwise it was just the usual docker pull, docker stop, docker run.

Maybe you want to remove “–restart always” and run it as a foreground container (without “-d”), so that you see what happens?

I see you use ADMIN_TOKEN but otherwise no environment. Did it work OK before? (if yes, where did it get the configuration from?)

Hi @cksapp,
no i did not read this, because i updated to v1.30.0 and v1.31.0.
Is there a link between the note and v1.30.0.


Hi @reinob ,
thanks for the quick response.
I also use the docker commands for updating. Portainer is just fo having a quick look :slight_smile:

I removed “–restart always” and run the container in foreground (didn’t know that this is possible, sorry about my bad knowledge about this!
This is the output:
thread ‘main’ panicked at /root/.cargo/registry/src/index.crates.io-6f17d22bba15001f/tokio-1.33.0/src/runtime/scheduler/multi_thread/worker.rs:447:13:
OS can’t spawn worker thread: Operation not permitted (os error 1)
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

Do you have an idea what to do?

ADMIN_TOKEN i use from day0 and it works fine up to now. The configuration i managed in the admin web interface.


Hi @reinob @cksapp ,
i solved the problem by myself.
Debian Buster seems to be to old for 1.29.2 and newer versions.
A qick fix is --security-opt seccomp=unconfined see here https://github.com/dani-garcia/vaultwarden/issues/2497

So I have to update my host os.

Thx for your support.


Nope, you are absolutely correct I must have missed that and not realized the changes.

I haven’t yet updated my instance for testing just yet but I’m glad you figured out your solution needed :smiley:

Yes, after OS update, everything works fine.