Unable to recieve emails through VaultWarden

Here’s the docker compose I used. Am I doing something wrong?

version: ‘3.8’

image: vaultwarden/server:latest
container_name: Vaultwarden
restart: unless-stopped
- “49157:80”
- /docker/Vaultwarden/data/:/data/
- SMTP_HOST=smtp.gmail.com
- SMTP_SSL=true
- SMTP_FROM=your-myemail # Replace with your G-Suite email
- SMTP_USERNAME=myemail # Again, replace with your G-Suite email

i had to get a special password from gmail here

You’re on the right track with the app-password if you have 2FA on your account you’ll need to use the app password in place of your email password.

Be sure you have the correct SMTP setting according to

Setup steps

  1. On the device or in the app, for server address, enter smtp.gmail.com.

  2. For Port, enter one of the following numbers:

    • For SSL, enter 465.
    • For TLS, enter 587.

Also you may need to be sure to save the changes first, then attempt to send a test email to check your SMTP settings.