SMTP response error: incomplete response

I’m not proficient with Linux/coding/etc, so please be kind and patient. My wife has decided that having a word doc isn’t working for her anymore and wants to join my vaultwarden. I’ve been trying to send the invitation email, but it isn’t working.

What I’ve tried:

  • Gave app password within google account, got this response and failed
  • Tried it without the app password, got this response and failed
  • Tried with Force TLS checked, got a different response but failed
  • Tried with Port 587(?), got a different response but failed
  • Tried with SMTP Auth mechanism options, got a different response but failed
  • Changed password to ensure no character issues, got a different response but failed
  • Turned off PiHole, checked reverse proxy .conf for any relevant concerns, still failed

Here is the relevant information:

| Starting Vaultwarden |
| Version 1.23.0 |

| This is an *unofficial* Bitwarden implementation, DO NOT use the |
| official channels to report bugs/features, regardless of client. |
| Send usage/configuration questions or feature requests to: |
| |
| Report suspected bugs/issues in the software itself at: |
| |

[INFO] No .env file found.

[WARNING] The following environment variables are being overriden by the config file,

[WARNING] please use the admin panel to make changes to them:


[2021-11-22 10:58:55.221][request][INFO] POST /admin
[2021-11-22 10:58:55.223][response][INFO] POST /admin (post_admin_login) => 303 See Other
[2021-11-22 10:58:55.336][request][INFO] GET /admin
[2021-11-22 10:58:55.338][response][INFO] GET /admin (admin_page) => 200 OK
[2021-11-22 10:59:12.323][request][INFO] POST /admin/test/smtp/
[2021-11-22 10:59:22.409][vaultwarden::mail][ERROR] SMTP response error: incomplete response

[2021-11-22 10:59:22.410][response][INFO] POST /admin/test/smtp (test_smtp) => 400 Bad Request

Any help would be greatly appreciated.

Please test the testing tagged image and see what that does.
Also, try to enable SMTP_DEBUG=true and see if you get some more info back.

My personal settings for Google workspace which is used for my homelab, I also switched these to use my personal gmail account which sent correctly, hopefully this works for you.

Create app password as described by Google
SMTP Email Settings within Admin page

From Address: (your_gmail_address_or_alias)
From Name: (anything_you_like)
Username: (gmail_login_address)
Password: (app_password)

In my testing the three below combinations worked for me, in sending the SMTP test email to any given email address of your choice to test.


Secure SMTP SSL: enabled
Force_TLS: disabled
Port: 587


Secure SMTP SSL: disabled
Force_TLS: enabled
Port: 465


Secure SMTP SSL: enabled
Force_TLS: enabled
Port: 465

Also be sure when you make any changes to the SMTP settings in the Admin page, you will first need to Save settings successfully then enter your email address for the test SMTP email.

While I appreciate the help, I don’t know how to do what you are suggesting. I have Vaultwarden in a docker via Unraid.

Corrected the issue and here’s how I did it. I retraced my steps with the app creation in google. previously had chosen “other” for Select App, when I should have chosen “mail”. Once I did that it worked.

Thanks for helping me retrace my steps.

1 Like