(Solved) [Error] When I try and login to my vault I immediately get logged out

Greetings, whenever I try and login into my vault I get logged out instantly, I’m using Haproxy as a reverse proxy with ssl configured I created the certificate with certbot I then concatenated the cert and key file together.

Error in the service status

Error in the browser

File configs

haproxy.cfg (I have balance roundrobin and check weight because I want to cluster the service later)

If you have stumbled upon this error or you have used other proxies to successfully implement https and want to share your experience I would appreciate it in any case. Thank you in advance!

Last time I ran into a similar issue I was testing upgrading from a really old version (bitwardenrs/server:1.10) to the newest version (vaultwarden/server:testing) and I noticed that I had to delete all the data/rsa_key.* files. Have not looked into the why.

But if you are using multiple vaultwarden instances make sure that they have the same rsa_keys (I think there are some existing threads with more information.)

1 Like

Thank you for the prompt reply, I deleted the key files in the data directory and tried again and it worked!


I’m using ceph as a shared storage for the data directory and I’m only running one instance currently, I must have messed up something in the reverse proxy config, now it should work properly even when I have several instances at the same time.

Thank you once again!! :grin::+1: