Enabling HTTPS....apologies if this has been asked numerous times

Hello all,

First time posting here, but I have been browsing for some time.

I really need your help as I feel like I’m banging my head against a brick wall. I’ve been on this task all weekend however no further along. I have read all the topics on this issue but can not find the cause of my problems.

I have Bitwarden running in a Docker (which I downloaded, not self composed) and it has been working great, both locally and remotely. I wanted to setup 2FA and so tried to login to the vault however I get the message that; “This browser requires HTTPS to use the web vault, Check the bitwarden_rs wiki for details on how to enable it.”

And so I set about reading up on everything I could find, however as I am new to all of this it is extremely difficult to make progress.

I have added the ROCKET_TLS variable as;
{certs="/usr/syno/etc/certificate/ReverseProxy/eca2c826-6adc-4a70-897c-f3bd97110b47/fullchain.pem" , key="/usr/syno/etc/certificate/ReverseProxy/eca2c826-6adc-4a70-897c-f3bd97110b47/privkey.pem"}
However I receive an I/O error when starting Bitwarden.

I tried the following SSH command (as someone suggested on another page on this forum) however it returned an error that it can’t connect;
curl -kv

I have tried to follow the following link as much as possible, however when trying to map port 80 to 443 (instead of 1025) I get a conflict error.

Lastly, the above link mentions that I need to mount the folder that the certificates are held. This is the only step I have not been able to do as I do not know how to within the docker image. I’m hoping that this may be the key to all of my problems.

Any assistance would be greatly appreciated.

I’ve spent the last few hours trying to mount the above certificate folder with a shared folder I set to NFS within Synology DSM. After several hours however I have found out that Synology uses a severely watered down version of Linux, which is missing a number of binaries. This would appear to be preventing me from mounting the folder and could possibly be the cause of all my problems.

Most people here probably aren’t Synology users, but given the error message, the first thing to check is that the paths in the ROCKET_TLS env var are the paths they would be in the bitwarden_rs container. I assume /usr/syno/etc/certificate/ReverseProxy/... is the path on the Synology host system, but you didn’t mention where you mounted the cert/key files into the container.