[RESOLVED] I cannot login via BW android app

Hi guys, I tried to login to my vw via BW android app, but failed.

The app is fdroid version and is downloaded from Releases · bitwarden/mobile · GitHub

I can login via web vault or BW chrome extension, and I can also login directly to BW cloud so app itself is fine I thinked.

I tried to set the server URL or custom env URL, to my vw domain, but both not work.

The app’s behaviors:

  1. When I typed the email and click ‘continue’, the app alerted “We cannot process your request. Please try again or contact us”.
  2. When I typed the password and click ‘login’, the app alerted “Error occured”.

(Both alerts are translated from zh-cn)

I tried to set LOG_LEVEL to trace but nothing logged when I click any button in app.

Sorry for poor English, but how can I diagnose it?

I suggest to read Connect Clients to your Instance | Bitwarden Help Center

You probably need to change the host.

What is the vaultwarden version you are using? Make sure you run the latest version 1.28.1 (i.e. the web-vault should say 2023.3.0)

I tried it before but not help :frowning:

Yes, I installed the vw yesterday via Docker vaultwarden/server:latest image.

Your environment (Generated via diagnostics page)

  • Vaultwarden version: v1.28.1
  • Web-vault version: v2023.3.0b
  • OS/Arch: linux/x86_64
  • Running within Docker: true (Base: Debian)
  • Environment settings overridden: false
  • Uses a reverse proxy: true
  • IP Header check: true (X-Forwarded-For)
  • Internet access: false (The server is in Mainland China so I guest the internet access detection is falsely false.)
  • Internet access via a proxy: false
  • DNS Check: true
  • Browser/Server Time Check: true
  • Server/NTP Time Check: n/a (Same reason as above.)
  • Domain Configuration Check: true
  • HTTPS Check: true
  • Database type: MySQL
  • Database version: 8.0.22-txsql
  • Clients used:
  • Reverse proxy and version:
  • Other relevant information:

Config (Generated via diagnostics page)

Show Running Config

Environment settings which are overridden:

  "_duo_akey": null,
  "_enable_duo": false,
  "_enable_email_2fa": true,
  "_enable_smtp": true,
  "_enable_yubico": true,
  "_icon_service_csp": "",
  "_icon_service_url": "",
  "_ip_header_enabled": true,
  "_smtp_img_src": "cid:",
  "admin_ratelimit_max_burst": 3,
  "admin_ratelimit_seconds": 300,
  "admin_session_lifetime": 20,
  "admin_token": "***",
  "allowed_iframe_ancestors": "",
  "attachments_folder": "data/attachments",
  "authenticator_disable_time_drift": false,
  "data_folder": "data",
  "database_conn_init": "",
  "database_max_conns": 10,
  "database_timeout": 30,
  "database_url": "*****://***************************************************",
  "db_connection_retries": 15,
  "disable_2fa_remember": false,
  "disable_admin_token": false,
  "disable_icon_download": false,
  "domain": "*****://************************",
  "domain_origin": "*****://************************",
  "domain_path": "",
  "domain_set": true,
  "duo_host": null,
  "duo_ikey": null,
  "duo_skey": null,
  "email_attempts_limit": 3,
  "email_expiration_time": 600,
  "email_token_size": 6,
  "emergency_access_allowed": true,
  "emergency_notification_reminder_schedule": "0 3 * * * *",
  "emergency_request_timeout_schedule": "0 0 * * * *",
  "enable_db_wal": true,
  "event_cleanup_schedule": "0 5 0 * * *",
  "events_days_retain": null,
  "extended_logging": true,
  "helo_name": null,
  "hibp_api_key": null,
  "icon_blacklist_non_global_ips": true,
  "icon_blacklist_regex": null,
  "icon_cache_folder": "data/icon_cache",
  "icon_cache_negttl": 259200,
  "icon_cache_ttl": 2592000,
  "icon_download_timeout": 10,
  "icon_redirect_code": 308,
  "icon_service": "internal",
  "incomplete_2fa_schedule": "0 * * * * *",
  "incomplete_2fa_time_limit": 3,
  "invitation_expiration_hours": 120,
  "invitation_org_name": "AnnAngela",
  "invitations_allowed": true,
  "ip_header": "X-Forwarded-For",
  "job_poll_interval_ms": 30000,
  "log_file": null,
  "log_level": "debug",
  "log_timestamp_format": "%Y-%m-%d %H:%M:%S.%3f",
  "login_ratelimit_max_burst": 10,
  "login_ratelimit_seconds": 60,
  "org_attachment_limit": null,
  "org_creation_users": "",
  "org_events_enabled": false,
  "org_groups_enabled": false,
  "password_hints_allowed": true,
  "password_iterations": 600000,
  "reload_templates": false,
  "require_device_email": false,
  "rsa_key_filename": "data/rsa_key",
  "send_purge_schedule": "0 0 * * * *",
  "sendmail_command": null,
  "sends_allowed": true,
  "sends_folder": "data/sends",
  "show_password_hint": false,
  "signups_allowed": false,
  "signups_domains_whitelist": "",
  "signups_verify": true,
  "signups_verify_resend_limit": 6,
  "signups_verify_resend_time": 3600,
  "smtp_accept_invalid_certs": false,
  "smtp_accept_invalid_hostnames": false,
  "smtp_auth_mechanism": null,
  "smtp_debug": false,
  "smtp_embed_images": true,
  "smtp_explicit_tls": null,
  "smtp_from": "**********************",
  "smtp_from_name": "Vaultwarden",
  "smtp_host": "******************",
  "smtp_password": "***",
  "smtp_port": 465,
  "smtp_security": "force_tls",
  "smtp_ssl": null,
  "smtp_timeout": 15,
  "smtp_username": "**********************",
  "templates_folder": "data/templates",
  "tmp_folder": "data/tmp",
  "trash_auto_delete_days": 30,
  "trash_purge_schedule": "0 4 0 * * *",
  "use_sendmail": false,
  "use_syslog": false,
  "user_attachment_limit": null,
  "web_vault_enabled": true,
  "web_vault_folder": "web-vault/",
  "websocket_address": "",
  "websocket_enabled": true,
  "websocket_port": 3090,
  "yubico_client_id": null,
  "yubico_secret_key": null,
  "yubico_server": null

Can you check your network settings of your android? Is the vaultwarden server publicly accessible? If not, has your android device access to your server? If you have set up some authentication or something like ModSecurity this might not work too.

The vaultwarden server is publicly accessible. (You can tried: https://vaultwarden.annangela.cn/ but as above the server is in Mainland China so the latency may be high.)
I can login the web vault via my android browser directly. Just not able in BW app.

I get a 403 forbidden error so it might not be open to every ip address.

Sorry for that. I made a mistake in apache2 config. The issue is addressed.

Sorry for wasting your time and thanks for your patience in answering.