"Registration not allowed or user already exists"

I am setting up Vaultwarden for my second time on another server. The first server worked perfectly. The settings on this second server are identical (with the exception of the smtp and url information due to different domain settings). This second server continually gives me a “Registration not allowed or user already exists” error when any user tries to follow the invitation link and create their new user and password. I have created invitations from the admin panel. Then I go to the email account for the new user and click on the “Join Organization Now” button in the message. In the next screen that pops up, I choose “Create Account” and begin filling in the password and other fields to finish the process. Every time I get the same warning, “Registration not allowed or user already exists.” Allow invitations is set to “true” in the admin panel as well.

I have removed Vaultwarden from the server, erased all appdata for Vaultwarden, and reinstalled 4 times and still have no success. I have tried rebooting the server as well. Nothing will allow me to create a single user. Help?!

System Specifications:
Server OS: Unraid
Vaultwarden Version: 1.26.0
Vaultwarden is behind a Swag reverse proxy

What do the logs say? Are there entries in the user overview in the admin panel? And can you post the support string from the diagnostics page?

Yes there are users in the overview panel.
It shows up in the page, but only has “Invited” listed at the bottom of the user info.
It also says the user was never active.

Here are the logs and support string:

[2022-11-26 06:10:17.168][start][INFO] Rocket has launched from
[2022-11-26 06:10:24.472][request][INFO] GET /admin
[2022-11-26 06:10:24.473][vaultwarden::auth][ERROR] Issuer is invalid
[2022-11-26 06:10:24.473][vaultwarden::api::admin][ERROR] Invalid or expired admin JWT. IP:
[2022-11-26 06:10:24.473][_][WARN] Request guard `AdminToken` is forwarding.
[2022-11-26 06:10:24.473][response][INFO] (admin_login) GET /admin/ [2] => 200 OK
[2022-11-26 06:10:53.362][request][INFO] POST /admin
[2022-11-26 06:10:53.370][response][INFO] (post_admin_login) POST /admin/ => 200 OK
[2022-11-26 06:11:00.313][request][INFO] GET /admin/users/overview
[2022-11-26 06:11:00.321][response][INFO] (users_overview) GET /admin/users/overview => 200 OK
[2022-11-26 06:11:16.893][request][INFO] POST /admin/users/********-****-****-****-************/delete
[2022-11-26 06:11:16.968][response][INFO] (delete_user) POST /admin/users/<uuid>/delete => 200 OK
[2022-11-26 06:11:18.588][request][INFO] GET /admin/users/overview
[2022-11-26 06:11:18.590][response][INFO] (users_overview) GET /admin/users/overview => 200 OK
[2022-11-26 06:11:32.848][request][INFO] POST /admin/invite/
[2022-11-26 06:11:33.900][response][INFO] (invite_user) POST /admin/invite => 200 OK
[2022-11-26 06:11:35.691][request][INFO] GET /admin/users/overview
[2022-11-26 06:11:35.696][response][INFO] (users_overview) GET /admin/users/overview => 200 OK

Your environment (Generated via diagnostics page)

  • Vaultwarden version: v1.26.0
  • Web-vault version: v2022.10.0
  • Running within Docker: true (Base: Debian)
  • Environment settings overridden: true
  • Uses a reverse proxy: false
  • Internet access: true
  • Internet access via a proxy: false
  • DNS Check: true
  • Time Check: true
  • Domain Configuration Check: false
  • HTTPS Check: true
  • Database type: MySQL
  • Database version: 10.6.10-MariaDB-log
  • Clients used:
  • Reverse proxy and version:
  • Other relevant information:

Config (Generated via diagnostics page)

Show Running Config

Environment settings which are overridden: SIGNUPS_ALLOWED, INVITATIONS_ALLOWED, ADMIN_TOKEN

  "_duo_akey": null,
  "_enable_duo": false,
  "_enable_email_2fa": true,
  "_enable_smtp": true,
  "_enable_yubico": true,
  "_icon_service_csp": "",
  "_icon_service_url": "",
  "_ip_header_enabled": true,
  "admin_ratelimit_max_burst": 3,
  "admin_ratelimit_seconds": 300,
  "admin_token": "***",
  "allowed_iframe_ancestors": "",
  "attachments_folder": "data/attachments",
  "authenticator_disable_time_drift": false,
  "data_folder": "data",
  "database_conn_init": "",
  "database_max_conns": 10,
  "database_timeout": 30,
  "database_url": "*****://***********:***%*******@*******:****/***********",
  "db_connection_retries": 15,
  "disable_2fa_remember": false,
  "disable_admin_token": false,
  "disable_icon_download": false,
  "domain": "*****://***********.******************.***/",
  "domain_origin": "*****://***********.******************.***",
  "domain_path": "",
  "domain_set": true,
  "duo_host": null,
  "duo_ikey": null,
  "duo_skey": null,
  "email_attempts_limit": 3,
  "email_expiration_time": 600,
  "email_token_size": 6,
  "emergency_access_allowed": true,
  "emergency_notification_reminder_schedule": "0 5 * * * *",
  "emergency_request_timeout_schedule": "0 5 * * * *",
  "enable_db_wal": true,
  "extended_logging": true,
  "helo_name": "**************",
  "hibp_api_key": null,
  "icon_blacklist_non_global_ips": true,
  "icon_blacklist_regex": null,
  "icon_cache_folder": "data/icon_cache",
  "icon_cache_negttl": 259200,
  "icon_cache_ttl": 2592000,
  "icon_download_timeout": 10,
  "icon_redirect_code": 302,
  "icon_service": "internal",
  "incomplete_2fa_schedule": "30 * * * * *",
  "incomplete_2fa_time_limit": 3,
  "invitation_expiration_hours": 120,
  "invitation_org_name": "**********",
  "invitations_allowed": true,
  "ip_header": "X-Real-IP",
  "job_poll_interval_ms": 30000,
  "log_file": null,
  "log_level": "Info",
  "log_timestamp_format": "%Y-%m-%d %H:%M:%S.%3f",
  "login_ratelimit_max_burst": 10,
  "login_ratelimit_seconds": 60,
  "org_attachment_limit": null,
  "org_creation_users": "",
  "password_hints_allowed": true,
  "password_iterations": 100000,
  "reload_templates": false,
  "require_device_email": false,
  "rsa_key_filename": "data/rsa_key",
  "send_purge_schedule": "0 5 * * * *",
  "sends_allowed": true,
  "sends_folder": "data/sends",
  "show_password_hint": false,
  "signups_allowed": false,
  "signups_domains_whitelist": "",
  "signups_verify": false,
  "signups_verify_resend_limit": 6,
  "signups_verify_resend_time": 3600,
  "smtp_accept_invalid_certs": false,
  "smtp_accept_invalid_hostnames": false,
  "smtp_auth_mechanism": "Plain,Login",
  "smtp_debug": false,
  "smtp_explicit_tls": null,
  "smtp_from": "***************@*****.***",
  "smtp_from_name": "*************",
  "smtp_host": "****.*****.***",
  "smtp_password": "***",
  "smtp_port": 587,
  "smtp_security": "starttls",
  "smtp_ssl": null,
  "smtp_timeout": 15,
  "smtp_username": "***************@*****.***",
  "templates_folder": "data/templates",
  "tmp_folder": "data/tmp",
  "trash_auto_delete_days": null,
  "trash_purge_schedule": "0 5 0 * * *",
  "use_syslog": false,
  "user_attachment_limit": null,
  "web_vault_enabled": true,
  "web_vault_folder": "web-vault/",
  "websocket_address": "",
  "websocket_enabled": false,
  "websocket_port": 3012,
  "yubico_client_id": null,
  "yubico_secret_key": null,
  "yubico_server": null

Seems like you did not configure your DOMAIN correctly.