Issue with Web Vault v2.12.1 (bitwarden_rs v1.14) on DS918+

So, we’ve been running Bitwarden on our Synology for a few months now, love it–it’s awesome!

But recently I tried to import my 1Password vault, and it kept saying there was an error. So what did I do? I kept trying.

Turns out, it was importing. Every. Time.

So now I have like 8 or so copies of every login/etc. When I log in using the desktop or mobile clients, I can see everything. When I log into the web vault, however, it spins for a bit, shows me my folders but there’s nothing there at all. I refresh, nothing. the logs are less than helpful, however.

What can I do to help make this process easier for me (the webvault will let me check & delete multiple items at a time, unlike the desktop or mobile clients)? Is there an “increase log level” environment variable I can tag into the docker config or .json file?

We’re running DS918+ on DSM 6.2.3-25426
Docker image for bitwardenrs-server is configured with CPU priority Medium, 512MB of RAM, Rocket workers 10.

Thank you so much in advance!

Not sure what version 2.12.1 refers to, but try pressing F12 to open the browser dev tools and see if there are any failed requests.

If you kept database backups, it would probably be easier to roll back to an earlier version of the database rather than delete all the duplicates.

You should also make sure to update bitwarden_rs regularly. There was an issues with imports fixed a few months ago, but not sure if it’s the same problem as yours:

Hello @gsieb,

If you are still using the web-vault version 2.12.1 then you are probably also using bitwarden_rs version lower then 1.14.1 which has a fix for the imports.

I suggest to update to the latest version of bitwarden_rs to fix this.
If it still doesn’t fix your issues please let us know.

Thanks, @BlackDex and @jjlin, I have since updated the bitwardenrs-server:latest to what appears to be 2.14.0 when I look at the Bitwarden web vault. It still, however, when I log into said web vault, won’t show my vault entries. I can’t roll back the database, because I hadn’t backed it up–and there are other users involved here. If I could just see my dang entries in the web vault I can easily take care of the duplicates.

When I log into the web vault and with dev tools open, I got some errors. Not sure if they’re related to much, but here’s a pastebin:

From the Diagnostics admin panel:



Server Installed Ok


Server Latest


Web Installed Ok


Web Latest



DNS ( Ok

Date & Time (UTC) Ok

Server: 2020-06-16 21:11:03 Browser: 2020-06-16 21:11:05

Thanks again!


Requests would be shown under the Network tab of the dev tools. Failures are generally highlighted in red.

For you, it might be easiest to just export your entries to the Bitwarden JSON format and delete your account. Then clean up the export, recreate your account, and import the cleaned up entries. Make sure to back up the entire SQLite database before doing any of this. Also, the JSON export doesn’t export attachments, so if you have any of those, you’ll have to download them manually. There is also, but I haven’t used it myself.

Thanks, @jjlin, this is what I ended up doing.

Thanks, everyone, for your help!