iOS Apps keeps crashing

Currently running the latest version of bitwardenRS on docker (via a VM), using Traefik as a reverse proxy. Unfortunately whilst the service works for the browser addons the app crashes every time I attempt to log in.

I have tried initially with my daily driver (iPhone 11, 13.5.5, uncover jailbreak) which didn’t work and I initially thought the jailbreak was causing the issues, so I rebooted to test this and the same thing happened. Tried again on my iPad (13.5), same issue. Then on my wife’s iPhone (iOS 14, iPhone 12 Pro), never jailbroken and the exact same issue occurs.

I have tried with Duo being activated and deactivated, same result.

I can get into the app, put in the selfhosting details but as soon as I log in with the details it crashes.

Any tips to get around this or should I give it up as a bad job until a new version for the server rolls out, or one for the app too?

Does the app work with the official BW server?

If no - then you should really report the issue at Issues · bitwarden/mobile · GitHub

Otherwise - do you see any logs on the BW side?

Thanks for replying. Yes it works with the standard server ok.

There are no logs on the server even mentioning a connection. When I use the direct address (through port 3012) it comes up with a websocket error.

Otherwise I can access the vault through my reverse proxy and through the web extensions.

Port 3012 isn’t a direct connection, it’s only used for websockets, which have no effect on mobile clients.

Also, https is needed for mobile clients in most situations. And the certificate needs to be valid.

Also, could you let us know which version of bitwarden_rs you are running?

Thanks for getting back to me. Finally got a basic grip on what everything is doing but I can’t get the iOS app to work.

I am using Traefik with Lets Encrypt to provide me with my certificates, which are all valid and up to date (have no other issues with accessing the sites forwarded to on any thing else on my server). I downloaded them and accepted them on my devices as well to no avail.

The main issue in troubleshooting this is that the connection doesn’t seem to be reaching as far as the server to be logged, so I’m completely in the dark and it definitely seems like an issue with the app for self-hosted servers.

I’ll throw an issue up on the git for the mobile to see if there is anything else that can be done. Otherwise that will end my short journey into using Bitwarden unfortunately.

Well, of the issue is your setup, that will not help your report on the issues. They will also send you back to us.

Could you try an other proxy maybe? Like nginx or haproxy?
Also, please share more details, like config, versions, etc…

Just worked it out. It was actually thanks to the logs of the Nextcloud iOS app that pointed me in the write direction.

  #- --entrypoints.https.http.middlewares=chain-oauth@file
  - --entrypoints.https.http.tls.options=tls-opts@file`

Had the the oauth chain un-commented which mean that it was set globally meaning this:

  - "traefik.http.routers.bitwarden-rtr-bypass.middlewares=chain-no-auth@file"

Was being ignored!

Thanks for your help and time! Apologies for wasting it :man_facepalming: