Errors while importing from a bitwarden backup csv


I installed BW on Synology NAS with Docker, and I try to import a backup from my old BW instance. The backup is in CSV format, but the problem is the same with JSON

First, I tried to import the whole file, and at the end of the import, I had the following popup :


I supposed that the problem came from the size of the file (it’s a big file), so I tried to import it in several parts, and I got the strange following behaviour :

  • When I import the first part, the import always ends, without error.
  • When I import the second part after the first, I get the same popup as above and the container is unstable and slow : I have to kill and recreate it.
  • If I kill the BW container and recreate it, and I import the first and second part as one part, it works without error, but if I try to import another part after that, I get the same unstable behaviour.

As I said, the file comes from another BW instance, so it can’t be malformed.

Can you help me ? Thanks in advance

I think this is because of the reverse proxy configuration. It looks like it doesn’t allow PUT requests.
Other could be that the you need to configure the allowed body size of the reverse proxy.

Both could not be an issue of bitwarden_rs it self, since it allows all of them.

Thank you for your answer. Unfortunately, I tried to disable the reverse proxy and access BW with HTTP temporarily to import my file, but BW gives me an error saying that my browser needs HTTPS. And I can’t change the size of the payload of the reverse in the DSM reverse proxy configuration tool, the option does not exist.

I tried to access it with IE11, but it’s too old and the vault doesn’t display correctly. I can’t login.

I’m stuck… :frowning:

Is there a way to proceed to a bulk import of the file directly into database via command line ?

I’ve just tried to import data with BW CLI (bw import bitwardenjson myfile.json), but with no success. The error is still the same.

I don’t know if you have found the solution.
But on my side I’ve got the same error.
And the solution I find is to increase the timeout value.
See here : Error when importing data from EnPass - #3 by MilesTEG1