Wrong TOTP caused by wrong server time

I am trying to log in and the TOPT code is asked. When i try to insert the code this error message is returned:

[2021-04-05 17:36:56.362][bitwarden_rs::api::core::two_factor::authenticator][ERROR] Invalid TOTP code! Server time: 2021-04-05 15:36:56 UTC IP:

I run bitwarden-rs official container and have full privileged access.
I used this installation in the last 2 months without problem.

I noticed today my host server’s (ubuntu 20.04) timezone was wrong, but the time was correct until we had to change the clock some day ago. Today I changed the timezone in the host machine, but the container timedidnt change.

I tried to create a volume to share the time like shown here:

This corrected the container system’s time but not the service time, as you can see from the log line up here.

Now basically the server time is 2 hours behind the actual time and this mess up with TOPT, how can I change the container time and timezone or make it synchronize with the host?

Please check the /admin/diagnostics page.
There you will see the UTC time, if the UTC time is correct, then it should work.
I live in a country where we just switched over to summer-time also, and i have no issues.

All OTP Codes are generated based upon UTC Timezone.
The only thing what can happen is, that if you modify your time instead of changing the timezone of you computer. mobile phone etc… that that device will run out of sync of UTC, which in turn could cause an issue like this.

I run into the same issue. I can not login to my vault with 2FA.

Invalid TOPT Code! Server Time …

The mentioned time is 2 hours behind my summertime.
Bitwarden Diganostics shows, eg:
Server: 2021-04-16 09:51:56 UTC
Browser: 2021-04-16 09:51:56 UTC

the Linux System itself is identical to it.
Current default time zone: ‘Europe/Berlin’
Local time is now: Fri Apr 16 11:52:51 CEST 2021.
Universal Time is now: Fri Apr 16 09:52:51 UTC 2021.

While recreating the container didn’t. Restarting the host machine resolved the issue for me.

A week ago I resettet my phone. I am using the Microsoft Authenticator App. I needed to delete the 2FA in Bitwarden and the Account in APP. After recreating 2FA everything works as expected.
It seems, that the backup from the AuthApp doesn´t work well ?