Where do I even put the SMTP settings?

How did you guys get the SMTP to show up in settings? My Account Settings doesn’t have an SMTP section

You need to either configure it via the docker variables.
Or via the /admin interface.

The web-vault account settings are for the user only, not server settings.