Vaultwarden doesnt work since DSM 7 update Synology


I ve just updated my Synology to DSM 7. However my vaultwarden is not working anymore. Here the problem :

  • i can access to HTTP link but cant login because vaultwarden works only in HTTPS
  • I can’t access to HTTPS because i have a “404 not found nginx” page.

I tried to uninstall / reinstall but nothing happened.
I checked my port in the docker (7002 + 7003) + reverse proxy (7024 for going in https and 7003 for http)
My certificate is good and worked great befofre the DSM update. The certificate is choosen for my vaultwarden docker.

I checked google and found this : Tutorial - Securing your Vaultwarden install | - The Unofficial Synology Forum

Seems iam not the only one with this problem. If iam wrong or if someone could help… ! Thx a lot !

I have a Synology NAS, and installed the DSM7 RC and after update to DSM 7 final without problems with my Vaultwarden, except with my websocket script witch no more works because of changes of a .conf in nginx folder.
But except this, I could access in HTTPS to my vaultwarden.

Have you checked your reverse proxy entry ?

For the websocket notfications, you may look at my tutoriel here (in French sorry :sweat_smile: ), at section : 5- Ajout d’un script pour les notifications Websocket

PS : how did you installed the vaultwarden container ?
Did you use docker-compose or Portainer ? Or DSM Docker UI ?
for a docker-compose.yml file, look at docker-compose-v4.0.yml in my tutorial :slight_smile: