Update non-docker server to 1.25.0

I am having an issue updating Vaultwarden to the latest versions. I am running it on an Ubuntu 22.04 Container on a Proxmox host and it is working fine with version 1.24.0. However, I do like to keep things up to date because otherwise when upgrades become imperative they tend to be more problematic.

in the past I have used this sequence of commands to bring my instance up to the current versions:

wget https://raw.githubusercontent.com/jjlin/docker-image-extract/main/docker-image-extract

chmod +x docker-image-extract

./docker-image-extract vaultwarden/server:alpine

systemctl stop vaultwarden

cp output/vaultwarden /opt/vaultwarden

cp -R output/web-vault /opt/vaultwarden

rm -R output

rm docker-image-extract

systemctl start vaultwarden

When I run this sequence today on a system with current specs as shown below, it appears to run just fine, and the service is up and running on the container again but the web interface is no longer accessible. I have confirmed with netstat that the vaultwarden service is listening on the same port but I cannot access the instance via the URL.

I have rolled back to the working version for now, but would like to know what further troubleshooting I can do to identify and resolve the issue. I searched through the forum but all other upgrade issues seem to be docker related and not applicable. Any ideas?

Thanks for an awesome piece of software!

Server Installed Update
1.24.0
Server Latest
1.25.0
Web Installed Update
2.25.1
Web Latest
2022.05.0
Database
**SQLite:** 3.35.4

### Checks

Running within Docker
**No**
Environment settings overridden
**Yes**
Uses a reverse proxy
**Yes**
IP header Match
**Config/Server:** X-Real-IP
Internet access Ok
**Yes**
Internet access via a proxy
**No**
DNS (github.com) Ok
140.82.114.3
Date & Time (Local)
**Server:** 2022-06-12 13:03:50 -04:00
Date & Time (UTC) Ok
**Server:** 2022-06-12 17:03:50 UTC**Browser:** 2022-06-12 17:03:51 UTC

I Would double check the port Vaultwarden is running on.
I think that is not the same as it was before because of some changes to Rocket (The web-server library).

I haven’t had a chance to dig deeper yet but with v1.24.0 when i check the vaultwarden service status it says ‘Rocket has launched from http://0.0.0.0:8000

Based on my notes when I updated to 1.25.0 the status said ‘Rocket has launched from http://127.0.0.1:8000

The port doesn’t seem to have changed, but the internal listening logic is slightly different. I don’t see why this should block traffic since it’s still listening on the loopback but perhaps I’m missing something.

I will try to poke this further later.

But if your reverse proxy doesn’t connect to the localhost then it will not work.

I followed the official ‘Pre-built Binaries’ deployment instructions and did not setup a reverse proxy on the container itself.

The instance is behind a network wide Caddy reverse proxy that is the front end for a variety of services I am hosting.

Is there a configuration file I can change to allow the service to continue listening on the physical interface with v1.25?

Just configure ROCKET_ADDRES=0.0.0.0 that would solve it for you.

Edit: I found the link in the service file.
For others who might experience this, adding ‘ROCKET_ADDRESS=0.0.0.0’ to /var/lib/vaultwarden/.env restored access after updating to v1.25

Thanks for your help BlackDex!

Original: Where do I make this change? All documentation assumes docker is being used and is not applicable. The only configuration file I have found is data/config.json and it does not have any related options currently specified. Attempting to add a json formated version of the proposed modification has no effect.