[SOLVED] Missing Dockerfiles after pulling latest image

Hello everyone,

i tried to Update my Bitwarden_rs today and ran into some problems. I previously used docker-compose to build and run the containers i needed. So after pulling the newest Updates from the git repository i tried to compile the new Version. However this lead to some problems.

I used mysql as a database so far, instead of sqlite, which lead me to give the following parameter in my docker.compose.yml:

    context: ./bitwarden_rs
    dockerfile: docker/amd64/mysql/Dockerfile

However this folder is no longer present after pulling the latest updates via git. I am pretty sure, that i did something different the last time around, but for the love of god: I can´t figure out , what excatly i did.

If any of you would have some advice, i would be very grateful.

Kind Regards

There are no longer separate images built for different database backends, so you should use docker/amd64/Dockerfile if you really want to build the image yourself. Is there some particular reason you don’t just use the pre-built images from https://hub.docker.com/u/bitwardenrs?

Hey @jjlin ,

i think i didnt know about those pre-built images back when i set up the server., which is why i compiled the image myself. Had to fix the dockerfile location, as you described and added the following to my docker-compose and it worked like a charm:

  DB: mysql