[SOLVED] First account creation does not work with self-hosted version on Raspberry Pi

I’ve successfully installed docker and bitwarden_rs to my Raspberry Pi yesterday (it was previously failing because of something wrong when installing docker, but eventually it worked…).
But when trying to create the first account on the web interface as described here : https://codeopolis.com/posts/running-bitwarden-on-a-raspberry-pi-with-docker/, the Submit button has totally no effect.
Is there anywhere I can check logs for this? I tried checking with "docker logs " but gave nothing after the last message telling that the machine is started.
I’m feeling like I need a self-hosted mail server to be able to send the email, but there’s nothing described around this so…
Thanks in advance for your help.

I tried and check the console on the client side (Firefox error console), and here is the log I’m getting when clicking on the “Submit” button :

vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:566 ERROR Error: Uncaught (in promise): TypeError: Cannot read property ‘importKey’ of null
TypeError: Cannot read property ‘importKey’ of null
at n. (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1
at Object.next (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1
at new t (zone.js:910)
at t (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at n.pbkdf2 (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at n. (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1
at Object.next (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at k (zone.js:831)
at zone.js:741
at o (main.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1)
at t.invoke (zone.js:391)
at Object.onInvoke (vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:624)
at t.invoke (zone.js:390)
at e.run (zone.js:150)
at zone.js:889
at t.invokeTask (zone.js:423)
at Object.onInvokeTask (vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:624)
mh @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:566
e.handleError @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:573
next @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:638
i @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:431
t.__tryOrUnsub @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1389
t.next @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1389
t._next @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1389
t.next @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1389
t.next @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:1474
t.emit @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:431
(anonymous) @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:624
t.invoke @ zone.js:391
e.run @ zone.js:150
e.runOutsideAngular @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:624
onHandleError @ vendor.ec1191668ddd60d16e05.js?sm_au=iVVD33rqZSQ2HMnVfQG0vKtC38MMJ:sourcemap:624
t.handleError @ zone.js:395
e.runGuarded @ zone.js:164
t @ zone.js:694
Zone.__load_patch.r.microtaskDrainDone @ zone.js:703
y @ zone.js:608
e.invokeTask @ zone.js:502
h @ zone.js:1744
v @ zone.js:1770


The error “Cannot read property ‘importKey’ of null”, means you need to enable HTTPS for it to work, the browser is blocking the required crypto apis when not on a secure domain (so either HTTPS or localhost)

Hello dani, thanks for your answer, somebody else also told me this, so I’ve tried to run this : https://github.com/dani-garcia/bitwarden_rs/wiki/Enabling-HTTPS.
This page is pointing to the other one https://github.com/dani-garcia/bitwarden_rs/wiki/Private-CA-and-self-signed-certs-that-work-with-Chrome that should help me creating the certificates, but I’m missing the part on where to move the generated files (certificates and keys and so on) to a place that they can be accessible by the docker machine, as the main page say “If following that guide your ROCKET_TLS line could look like this: -e ROCKET_TLS=’{certs=”/ssl/bitwarden.crt",key="/ssl/bitwarden.key"}’ "
Any advise on this please?

@briceparmentier this is also mentioned in the first article you link to. You need to add an extra volume like this -v /ssl/keys/:/ssl/ where /ssl/keys/ should be the path on the host where the keys are stored.

Damn it! This is that simple!
Thanks a lot @BlackDex, I completely misunderstood this part… I have to admit I’m a total newbie with docker so it doesn’t help a lot :stuck_out_tongue:
Thanks again!