No such recipient here ... 5xx error

Hello wise vaulters,

Super pleased with the setup of Vaulwarden and it’s been runing for a little while.
I’m trying to invite another user in a new organization. I’ve done this succesfully before.
I added the domain to the email domain whitelist and made a user. I got a message (see blockquote) that there is a permanent error: No such recipient here
Trying to send a test mail (from admin smtp settings) to anyone on the new domain gives and error. Strange. Emailing to other domains (through the send test) still works.
I have tried removing the domain whitelist, restarting, leaving allow new signups active. But no luck.

I wonder if there is a whitelist that I’m unaware off that is somewhere else to update.

The domain I’m testing too has a mailserver and I can receive emails there.

And it’s not the SMTP settings I think because it still sends emails.

Does this sound familiar to someone, and would you be able to point me in the right direction?

Let me know if you need more information.


From debug log:

[2023-01-25 14:50:04.144][vaultwarden::mail][DEBUG] SMTP 5xx error: lettre::transport::smtp::Error >{
kind: Permanent(
Code {
severity: PermanentNegativeCompletion,
category: MailSystem,
detail: Zero,
source: “No such recipient here”,
[2023-01-25 14:50:04.144][vaultwarden::mail][ERROR] SMTP 5xx error: permanent error (550): No such recipient here
[2023-01-25 14:50:04.145][response][INFO] (test_smtp) POST /admin/test/smtp => 400 Bad Request

Version (running through home assistant. Vaultwarden is on it’s own domain, directed to add-on though Nginx Proxy Manager):

Add-on version: 0.19.0
You are running the latest version of this add-on.
System: Home Assistant OS 9.4 (amd64 / qemux86-64)
Home Assistant Core: 2023.1.7
Home Assistant Supervisor: 2022.12.1

Vaultwarden Version 1.27.0

Not sure I understand the issue. The error message is generated by the the receiving mail server and tells you that the recipient does not exist. :face_with_raised_eyebrow:

Thanks for responding!

The thing is that the recipient does exist.
I’ve also tried a recipient with a totally different address, domain that is, that works.

But this one domain gives errors. (I tried multiple differentuser@domain.tld) But from your message I understand that this error message doesn’t originate from vaultwarden or smtp server, but from the receivers domain responding server?

Then this domain.tld (emailing runs on Google Workspace) is configured wrong?

Thanks again for taking the time to look at this :blush:

The thing is that the recipient does exist.

At least not according to response from the mail server. Make sure you have no typo in the address. The SIGNUPS_DOMAINS_WHITELIST should be irrelevant here (as it is ignored both when testing the SMTP settings and also when inviting via the admin panel).

But this one domain gives errors.

Can you send mails to the domain (from another mail server)? If not, you might not have set the correct MX records

Hi stefan0xC,

thank you for that response. This has helped me into the direction, forgetting that it’s somewhere on the vaultwarden side, but focus soley on the domain.
Yes the domain has been working with emails for the last 15+ years, no issues.
But suddenly I remember that the website on this domain has recently changed hosts.
What we have done is pointed the A record for the root (A) to a different IP server where the website is hosted. All other records (like MX) still point to Google Workspace.
The thing is that I did not look at any of the settings of the new host for just the website, as it only served a website for the root. But there on that server was one mx record leading to itself, where no email was configured.

What I don’t understand is how vaultwarden pings that server, perhaps it looks at the A record of the @ roopt and asks about the server there. It didn’t go to the MX records straight.

I tried some other tests with another domain that I hosted just the website elsewhere (through the @ dns a record) and left everything else intact. That domain also acted up in the send test.

Perhaps this is what how it’s designed and I’m more to learn about smtp :wink:
I’ve added appropriate MX records for the domain on the new server (again, it’s not getting traffic for email, just the website) and after a little while, the vaultwarden picked it up and delivered the test message.

Thanks again for serving the community.