Mobile client push not working

I just updated the image to 1.29.0 to use the new mobile client push feature and set PUSH_ENABLED to true and filled out PUSH_INSTALLATION_ID & KEY. But when I create a new item with the browser extension I can’t see in the mobile app. I still have to manually refresh/synchronize the app to see the new item.
I’m running Vaultwarden behind a nginx proxy (GitHub - linuxserver/docker-swag: Nginx webserver and reverse proxy with php support and a built-in Certbot (Let's Encrypt) client. It also contains fail2ban for intrusion prevention.) and also not on port 443 or 80. I enabled debug logging but didn’t notice anything strange.

I suggest to read Using Bitwarden's push service · dani-garcia/vaultwarden · Discussion #2469 · GitHub

Maybe there is something there which can help or make it more clear on the workings.

Re-installing the iOS app solved the problem. After logging in, I also got a message that push sync could now be activated.

1 Like

Loving the new PUSH Sync on my devices! One thing I did encounter was that the feature doesn’t seem to be compatible with the F-Droid version of the Android app. Once I removed it and installed the Play Store version, everything worked perfectly.

F-Droid versions doesn’t contain the Google Play libraries.

1 Like

I couldn’t get it working on iOS. Even after uninstall, reboot, reinstall.
Tho I get the pop-up on my iOS device after my first log-in to allow push notifications.
But updates do not get pushed.

Is there some hint in the logs if the registration on the push server (using the Id & Key) is working at all?


I have 2 identical Valutwarden servers ver 1.29.0 registered on my iOS App. In the first push notifications work fine, in the second push notifications from App to Web work, but not the other way around. Something similar to the case reported by @kennymc.c

In my case, I’m running both servers behind two different Traefik reverse proxies. Logs do not show errors.

E.g., here is a create event from the browser:

vaultwarden  | [2023-07-13 14:45:46.253][request][INFO] POST /api/ciphers
vaultwarden  | [2023-07-13 14:45:46.340][response][INFO] (post_ciphers) POST /api/ciphers => 200 OK

Does anybody know how to troubleshoot this problem?

1 Like

Facing more or less the same issue.

By creating an entry on my iOS devices, I can see the changes being reflected immediately on the web vault and chrome extension.
Creating an entry within Chrome Extension/ Web Vault isn’t being reflected instant on my mobile devices.

I found the solution: Using Bitwarden's push service · dani-garcia/vaultwarden · Discussion #2469 · GitHub

you need to set up the host to US as location, to get push working correctly.