Error sending email templates

Dear Reader,

I have added a the default mail templates to the data folder and pointed the themplates folder in the .env file. But now I get an error when ever I send a mail:

[2022-11-19 18:26:30.343][response][INFO] (admin_page) GET /admin/ => 200 OK
[2022-11-19 18:26:38.255][request][INFO] POST /admin/test/smtp/
[2022-11-19 18:26:38.255][handlebars::render][DEBUG] Rendering value: Path(Relative(([Named(“img_src”)], “img_src”)))
[2022-11-19 18:26:38.255][error][ERROR] Handlebars.
[CAUSE] RenderError {
desc: “Variable "img_src" not found in strict mode.”,
template_name: Some(
line_no: Some(
column_no: Some(
cause: None,
unimplemented: false,
[2022-11-19 18:26:38.255][response][INFO] (test_smtp) POST /admin/test/smtp => 400 Bad Request
[2022-11-19 18:26:45.280][request][INFO] GET /

Does anyone know why I get this error?

Did you mixed and matched the correct templates with the correct version of Vaultwarden? It could be that you are either using older or newer templates which do not have the correct variables.

I just uploaded the templates that I got from the github page and after you suggested it I updated Vaultwarden, but still get the error. Im on version 1.26.0 now.

Those are still the wrong files.
Get them from the correct tag GitHub - dani-garcia/vaultwarden at 1.26.0

Or use the testing tagged docker image.

Now it works. Is the main github page not the page for the newest version?

The main branch is up to date with the newest testing image (which ships the unreleased version 1.26.0-7a767310). While the latest release (1.26.0) of vaultwarden (which is the version in the latest image) is a bit older and does not have the latest changes (e.g. the commit ea19c22 which changed the templates).

Oke, now I get it, thanks for the help you guys. :+1: