Vaultwarden Latest Docker - Unable to determine /Admin username

I’m on a fresh install. I have ADMIN_TOKEN enabled, and I’ve deleted any configs and regenerated my entire configuration multiple times.

Whever I access the /admin portal, I’m prompted for a username and password.

No matter what I do, I cannot get past this prompt. I’ve tried creating a user and using those credentials, I’ve tried user: admin and the admin_key for my password, I’ve tried making the Admin_key even more simple, I’ve tried disabling it entirely. There is nothing I can seem to do to access the /admin page. I always get a 403.

Please help. I’m pulling my hair out here.

Vaultwarden doesn’t have a basic auth feature. So this probably is something from the reverse proxy.

1 Like

Ack! You’re right! It probably should be commented out by default on the example. - Proxy examples · dani-garcia/vaultwarden Wiki · GitHub

I was looking at the example “Nginx (by shauder)”

I hadn’t bothered to double check the NGINX config outside of the upstream refs.