Unix sockets instead of ports


it would be great if one could bind to a unix socket instead of address:port.
So for example to: /opt/bitwarden_rs/socket instead of

Thank you

There is an open issue on the HTTP server we use, and also an old pull request:

Until those are solved there’s not much we can do.

1 Like

If you really want sockets you could try if socat works for you.

1 Like

Thank you. It’s more of a “I want to avoid ports” than a “I want to have sockets”, so there wouldn’t be anything achieved if I go with socat (but this you couldn’t know, so thank you very much anyway!)

No hard feelings towards the bitwarden_rs project, but I’m going just for somethings else. I could be wrong, but I don’t think rocket will have the issue solved anytime soon (which is no complain, since I’m just using things without contributing anything).

I’m only mentioning it, because it seems that I probably was alone with that request (within bitwarden_rs). So if no one else needs this feature, you can just close the request. Thanks anyway!

One question @bitwarden_rs_User : what is the reason for your wish? Maybe there is an alternative?

I am packaging bitwarden_rs for Syncloud project (open source self-hosting platform) where we have multiple apps for one user on a single device which may lead to port conflicts.
We use snap so there is no tcp isolation like in Docker for example.

Rocket issue is still open :frowning:

@bitwarden_rs_User there are two of us now! :slight_smile: