SMTP problem after last update

it’s my first topic, so first of all, thank for your great job.

Few days ago i upgraded from vaultwarden 1.21.0 (that was running very fine) to 1.22.1
Everything seemed to be okay but today i tried to send a test mail from admin panel getting error in a popup:
“Error sending SMTP test email

My setup is the same of before upgrade, didn’t change any configuration variable. The port is “25” and i can send mail from linux (CentOS 7) CLI.
My reverse proxy is apache.

Here are the logs of container:
[2021-07-05 11:53:47.128][response][INFO] POST /admin/test/smtp (test_smtp) => 400 Bad Request
[2021-07-05 11:56:52.273][request][INFO] POST /admin/test/smtp/
[2021-07-05 11:56:52.333][error][ERROR] Smtp.
[CAUSE] lettre::transport::smtp::Error {
kind: Connection,
source: Failure(
Error {
code: ErrorCode(
cause: Some(
Error {
code: 336130315,
library: “SSL routines”,
function: “ssl3_get_record”,
reason: “wrong version number”,
file: “…/ssl/record/ssl3_record.c”,
line: 332,
X509VerifyResult {
code: 0,
error: “ok”,

Could it be related to some smtp code change?

Thank you very much,

Maybe i’ve solved:
before the update “Enable Secure SMTP” was set to true and smpt worked fine.
Now i’ve had to uncheck that, leaving it “false” and smpt restarted working.

Thank you