Self-Signed Android setup

Hello, I’ve recently setup my VaultWarden server with a self-signed certificate and CA.
On my desktop, it works and I get no errors, however when trying to use the android app I get errors.

Error number 1: when trying to install just the certificate, I got Private key required. so I looked online, and create a pk12 to install both.

Error number 2: after doing numer 1, I tried to connect to my server but get: Trust anchor for certification path not found.

So I installed the root CA as well on the device, still no dice.

I followed this guide to a tee, including the ext file, which should solve this.

I know it’s not recommended, but it’s what I have now, and it is working on my browser.

I would appreciate any help on the matter.

Bitwardens help page refers to this community thread:

Thanks for your reply, I’ve tested every method on that post, aside from the last post, nothing worked. I always get the same error

I’m having the same issue. I have bitwarden hidden behind a nginx reverse proxy so the certificate is being used by the reverse proxy not bitwarden itself, but the mechanics should be the same. Did you ever figure it out?

Yes, in my case I had to create the VW cert (not the root CA) as a root CA as well, then import that on android everything worked after that.