Environment Variable WARNING

I’m running Bitwarden_RS version 1.19.0 on unraid as a docker container.

I would like to suppress the following WARNING & INFO:

  • [INFO] No .env file found
  • [WARNING] The following environment variables are being overriden by the config file,
  • [WARNING] please use the admin panel to make changes to them:

To prevent ‘No .env file found" message I placed a .env file under /mnt/user/appdata/bitwarden. Additionally, underExtra Parameters’ in the 'Unraid/Docker/Bitwarden/Advanced view, I have specified “–env-file /mnt/user/appdata/bitwarden/.env” (without quotes). After restarting the container, I still get the ‘No .env file found’. Why is my .env not getting loaded eventhough I’m specifying the --env-file parameter as mentioned?

To resolve the WARNING log message, I kept all the default settings for ‘SIGNUPS_ALLOWED’, ‘INVITATIONS_ALLOWED’, and ‘ADMIN_TOKEN’. Yet, I see the warning messages.

How do I complete prevent/avoid getting the above-mentioned INFO & WARNING messages?

The info message isn’t that bad, and only for info.
But if you really want to prevent them all, you need to remove the config.json and only use the .env file and never modify settings via the admin interface.

Just found this thread since I was looking for an answer.
Bumping it up for a simpler solution. So if anyone ever comes from a searchengine or something:
You can set a # in front of any setting in the config.json instead of removing it entirely. If you prefer to have some environment tables set to never break your instance e.g. domain or a never changeable admin token. :slight_smile: