# Unable to start Vaultwarden container on Synology Portainer install

**URL:** <https://vaultwarden.discourse.group/t/unable-to-start-vaultwarden-container-on-synology-portainer-install/4101>\
**Category:** Help\
**Created:** [October 21, 2024, 12:10am UTC](https://vaultwarden.discourse.group/t/unable-to-start-vaultwarden-container-on-synology-portainer-install/4101 "2024-10-21T00:10:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![d4w](https://avatars.discourse-cdn.com/v4/letter/d/fbc32d/32.png) [@d4w](https://vaultwarden.discourse.group/u/d4w)\
**Post date:** [October 21, 2024, 12:10am UTC](https://vaultwarden.discourse.group/t/unable-to-start-vaultwarden-container-on-synology-portainer-install/4101/1 "2024-10-21T00:10:59Z")

</div>

New install. Followed the mariushosting [steps here](https://mariushosting.com/synology-install-vaultwarden-with-portainer/)…

Problem:  
Container [Vaultwarden] error: curl: (7) Failed to connect to localhost port 4020 after 0 ms: Couldn’t connect to server

**Double checked configuration in Synology** :  
a) Reverse Proxy:  
General:  
Source is HTTPS, vaultwarden. xx. synology. me, port 443. HSTS checked.  
Destination: HTTP, localhost, port 4080  
Custom Header: Websocket. Upgrade: $http\_upgrade, Connection $connection\_ugrade  
b) Network/Connectivity: HTTP/2 is Enabled  
c) Security/Advanced: HTTP compression Enabled  
d) File Station: docker/vaultwarden/data and db folders created  
e) Portainer - Success Stack successfully deployed  
f) Portainer container - [Vaultwarden-DB] as running and in healthy state  
g) Firewall: Disabled firewall temporarily, but same result

Rechecked:

- Router: Port forwarded… External 443-\> Internal 443 (internal IP address)

Endless nights of testing, so any other suggestions would be greatly appreciated!

---

<div class="post-metadata">

**Author:** ![Partridge2562](https://avatars.discourse-cdn.com/v4/letter/p/13edae/32.png) [@Partridge2562](https://vaultwarden.discourse.group/u/Partridge2562)\
**Post date:** [October 24, 2024, 1:02pm UTC](https://vaultwarden.discourse.group/t/unable-to-start-vaultwarden-container-on-synology-portainer-install/4101/2 "2024-10-24T13:02:45Z")

</div>

I followed [this tutorial](https://www.youtube.com/watch?v=S-jwBdQVnMw) for synology and it works fine. It was on DSM 7.1 at the time and docker on DSM 7.2 has changed a bit so YMMV. No issues other than having to enable WebSocket notifications when configuring reverse proxy as someone commented on the video.

I use [this utility](https://github.com/mag37/dockcheck) for getting update notifications and it says “Not working well with containers created by **Portainer** ”. I would pick a tutorial without Portainer but I’m no docker expert and no DSM expert (yet have zero issues).

[This utility](https://github.com/Bruceforce/vaultwarden-backup) works great for backups on my synology setup.
