# Help fixing my instance

**URL:** <https://vaultwarden.discourse.group/t/help-fixing-my-instance/4033>\
**Category:** Help\
**Created:** [September 27, 2024, 4:05pm UTC](https://vaultwarden.discourse.group/t/help-fixing-my-instance/4033 "2024-09-27T16:05:30Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ignacio82](https://yyz2.discourse-cdn.com/free1/user_avatar/vaultwarden.discourse.group/ignacio82/32/1525_2.png) [@ignacio82](https://vaultwarden.discourse.group/u/ignacio82)\
**Post date:** [September 27, 2024, 4:05pm UTC](https://vaultwarden.discourse.group/t/help-fixing-my-instance/4033/1 "2024-09-27T16:05:30Z")

</div>

My vaultwarden container is giving me this error:

```auto
2024-09-27 16:01:53.577][vaultwarden::util][WARN] Can't connect to database, retrying: DieselCon.
[CAUSE] BadConnection(
    "could not translate host name \"vaultwarden-db\" to address: Temporary failure in name resolution\n",

```

Everything was running fine but this morning I woke up to this. Any suggestions for how to fix it? I tried restarting the vaultwarden and postgres container but i had no luck.

---

<div class="post-metadata">

**Author:** ![ignacio82](https://yyz2.discourse-cdn.com/free1/user_avatar/vaultwarden.discourse.group/ignacio82/32/1525_2.png) [@ignacio82](https://vaultwarden.discourse.group/u/ignacio82)\
**Post date:** [September 27, 2024, 8:28pm UTC](https://vaultwarden.discourse.group/t/help-fixing-my-instance/4033/2 "2024-09-27T20:28:30Z")

</div>

I figure out the problem. The postgres was updated and that created the problem. Rolling back to 16.4 solved the issue. Not sure if there is a way of migrating to 17 without breaking vaultwarden.

---

<div class="post-metadata">

**Author:** ![simon900900](https://avatars.discourse-cdn.com/v4/letter/s/e56c9b/32.png) [@simon900900](https://vaultwarden.discourse.group/u/simon900900)\
**Post date:** [September 28, 2024, 10:55am UTC](https://vaultwarden.discourse.group/t/help-fixing-my-instance/4033/3 "2024-09-28T10:55:45Z")

</div>

Same thing here (learnt my lesson from Watchtower), however when I repull the Postgres image for 16.4 I still get the same issue. @igancio82 Please can I ask how you rolled back and if you made any other change ?

i was also able to restore my previous vaultwarden folder from last week but still to no avail

I manage my container through portainer
